Your server is running PHP version 5.1.6 but WordPress 3.7.4 requires at least 5.2.4.